This project is read-only.

Not working on Server

Sep 1, 2016 at 2:07 PM
When I try to run my task on my server, then I get:
"TaskUnZip 2014:Error: The task has failed to load. The contact information for this task is ""."

I can run it without any problems on my dev. in VS 2015

The server is SQL server 2014
I have installed Task UnZip_SSIS_x64.msi on both my server and my dev pc.
The server has been restarted and the SQL Server Analysis Services has also been restarted (a couple of times)
I can see that the server has ProgettoMultimedia.TaskUnZip_2014.dll in the GAC (C:\Windows\Microsoft.NET\assembly\GAC_MSIL\ProgettoMultimedia.TaskUnZip_2014\v4.0_1.5.0.0__08d5a3e5c5e98dbc)
Sep 2, 2016 at 7:56 AM
I have solved the issue. the lib. ICSharpCode.SharpZipLib.dll needs to be manuel install on the server (via gacutil)
Sep 2, 2016 at 8:01 AM

thanks for your contribute.
This is strange, because this library, in last version of TaskUnzip is embedded into library.

Sep 2, 2016 at 8:05 AM
What version is installed on your server? It's possible to check, from "Info Panel" on SSIS Designer.
Sep 2, 2016 at 8:26 AM
I do not have VS installed on the server. If I take Properties on SSISDB on the server I see Schema Build 12.0.2000.8
Sep 22, 2016 at 6:47 PM
I have tried installing ICSharpCode.SharpZipLib.dll but I still get the error. Is there another reason for it not working on SQL Server 2014?

Version: 12.0.4100.1

Works fine on local machine with Visual Studio 2015

Executed as user: NACOKECCE_sql_proxy. Microsoft (R) SQL Server Execute Package Utility Version 12.0.4100.1 for 32-bit Copyright (C) Microsoft Corporation. All rights reserved. Started: 1:35:18 PM Error: 2016-09-22 13:35:18.94 Code: 0xC0010018 Source: TaskUnZip Description: Failed to load task "TaskUnZip", type "". The contact information for this task is "TaskUnZip:". End Error Error: 2016-09-22 13:35:19.09 Code: 0xC0010026 Source: TaskUnZip Description: The task has failed to load. The contact information for this task is "TaskUnZip:". End Error Error: 2016-09-22 13:35:19.11 Code: 0xC0024107 Source: TaskUnZip Description: There were errors during task validation. End Error DTExec: The package execution returned DTSER_FAILURE (1). Started: 1:35:18 PM Finished: 1:35:19 PM Elapsed: 0.297 seconds. The package execution failed. The step failed.
Sep 23, 2016 at 7:55 AM
Try to restart the ssis service and then reinstall the ssis packed.
Sep 23, 2016 at 3:01 PM
Thanks for reply. That didn't work for me. uninstalled, restarted ssis server.

Sep 24, 2016 at 3:42 PM
Hi R10