This project is read-only.

TaskUnzip not working when build without installation

Sep 21, 2016 at 10:46 AM

I have an SSIS project which uses the TaskUnzip task locally on my development machine (VS2015, SQL Server 2014).
Locally I have the task installed and the project works as expected.
In our configuration we build de SSIS projects (create the .ispac files) on a VM and from there we deploy to a database server in Azure.
On the database server (SQL Server 2014) the TaskUnzip is installed.
Using this workflow the package execution of the package fails on the TaskUnzip task.

However, If I create the .ispac locally on my machine and deploy that directly to the DB server (not an desired workflow as we want to deploy everything via the VM so that we are not dependent on the configuation of local machines) the package seems to work as expected.

I think the problem is due to the fact that the TaskUnzip is not installed on the VM.
However, when building the solution on the VM, we don't get any warnings/errors of a missing or unknown task.
Could this indeed be the option?
Is there anyway to be able to still build on the VM without having to install the TaskUnzip on the VM?

Kind regards,

Sep 24, 2016 at 6:46 PM
Edited Sep 24, 2016 at 7:11 PM
Hi Frank

well, I tried to reproduce your problem, but result is correct deploy and running of my "SSIS-Test-Task".

My test:
1) initialized a VM with SQL server Standard 2014 on Azure
2) initialized Integration Services Catalog (configure correct password)
3) installed: Task UnZip_SSIS_x64.msi

1) prepared my SSIS package (.ispac)
2) configured password: EncryptSensitiveWithPassword (same password of Integration Service Catalog)
3) build my SSIS-Test-Task
4) copied .ispac file on server and execute procedure to import into Integration Service Catalog
5) tried to run my package and verify correctly creation of file zip

For any further clarification, do not hesitate to contact me.

Sep 26, 2016 at 7:33 AM
Hi Goldfix,

Thanks for the test.
In step 3 you mention building the SSIS-Test-Task.
I take you build the task on a different machine than the VM?
Is the UnZip task msi installed on that machine?

My problem is that the building is done on a VM which has VS installed; but doesn't have the UnZip task msi installed.
I figured that might cause problems.

Kind regards,

Sep 26, 2016 at 8:55 AM
Hi Frank

I suggest you , to install Task UnZip_SSIS_x64.msi and retry.